Important: Please read the Qt Code of Conduct -

WebSocket with QtWebAssembly

  • Hello,

    yesterday i tried to compile the two websockets example with 5.13 gcc and everything works fine.

    After that i compiled the server with 5.13 gcc to run on my local machine and compiled the client with 5.13 emc (webassembly) to run inside my firefox. For the emc version i started "python -m SimpleHTTPServer 8080" a simple httpserver and tried to open "localhost:8080".

    As i can see the webassembly program is starting but hangs at "compiling"

    Does anywone knows why it does not finish the compiling process inside firefox? I would like to create a server application (5.13 gcc) with a socket that can communicate with another (5.13 webassembly) socket. The reason for that is to transfer serialized data from server to webassembly application.

    Side Note:
    I also tried it with an QSslSocket but as i see QSslSocket is disabled by Qt for emc.

    I created new Project with "QGuiApplication app(argc, argv);" and a QML file and added both classes now it is working!

    Now i tried to do the same with:

    Fehler: no member named 'sslErrors' in 'QWebSocket'
    connect(&m_webSocket, QOverload<const QList<QSslError>&>::of(&QWebSocket::sslErrors),

    Fehler: no member named 'ignoreSslErrors' in 'QWebSocket'

    Is there a Way to create SSL Websockt for WebAssembly?

Log in to reply