Application output “...exited with code -1073741511”



  • Hi everyone
    Since I am new to Qt, I need some help with configuration of the environment.
    I am trying to compile a project that I got from a colleague and I need to install the environment on a new PC.
    So the setup is as follows:
    -Windows 10
    -Qt 5.13 (tried also with Qt 5.12 LTS)
    -MSYS2 with packages installed:
    gcc-libs 9.1.0-2
    mingw-w64-x86_64-gcc 9.1.0-3
    mingw-w64-x86_64-gcc-libs 9.1.0-3
    mingw-w64-x86_64-boost 1.70.0-2
    (https://packages.msys2.org/base)

    When I execute the code I get the error on the Application output window

     “...exited with code -1073741511”
    

    Also, I get the following screen
    0_1565788735746_a61692c2-4321-4506-abf6-4ffe60f1fa0f-image.png

    Instead I should get a GUI+small console window with text output.
    This happens when I run from within Qt.
    When I run the standalone .exe from the Build folder I get the following error about Entry Point
    0_1565789096046_392961fa-8140-4838-a936-4b0bf421f784-image.png

    • So are there any suggestions on what is wrong with this?

    • list itemMaybe compiler and Qt version compatibility?

    • Other configuration?

    Thanks a lot!

    p.s. I hope this is the correct forum category


  • Qt Champions 2018

    Hi @qtea ,

    it seems you are not using the MinGW bundled with Qt, right?

    If yes, you are already on your own, as no one can promise you any compatibility then. You may even need to compile Qt your self.

    Does a minimal hello world project build and run at least?

    And can you debug it?

    Regards



  • Hi @aha_1980
    Ther you go, the minimal project does run fine
    0_1565865443132_Capture1.PNG

    " it seems you are not using the MinGW bundled with Qt, right?"
    Yes it is a packaging of MinGW with the necessary Boost libraries in it (https://www.boost.org/), all precompiled binaries.

    What should I expect in the Debug operation?!

    Regards and thanks for helping!


  • Qt Champions 2018

    Hi @qtea,

    Ok, so it is working properly.

    What should I expect in the Debug operation?!

    I just want to know if the debugger works, it may help us to analyse problems later.

    So can you stop at the breakpoint and inspect the local variables?

    The next step I'd take would be a Qt GUI application. If that runs successfully, you can start analysing your own program.

    Place a breakpoint at the very beginning and see if you can run till there.

    If not, probably some DLLs are not loaded and therefore it crashes.

    In the worst case that means, you should have to remove functions from your program until it runs to find the guilty part.

    Regards


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.