XCB QPA backend missing when configuring Qt



  • Hi,

    I'm currently trying to build Qt on a Nvidia Jetson AGX. Ready for use together with GStreamer.
    When building the GStreamer plugins it told me that X11Extras are missing.

    While investigating into this I stumbles across some other information in the dev forum but without a clear answer or hint to my problem.

    But something is curious when I configure Qt -> there is no XCB QPA backend which is in my opinion the cause for the missing x11extras.

    I'm using qt-everywhere-src-5.13.0.

    My configure call:

    ./configure -prefix /opt/Qt5.13 -nomake examples -v
    

    Relevant configure output:

    Features used by QPA backends:
      evdev .................................. yes
      libinput ............................... no
      INTEGRITY HID .......................... no
      mtdev .................................. no
      tslib .................................. no
      xkbcommon .............................. no
      X11 specific:
        XLib ................................. yes
        XCB Xlib ............................. yes
        EGL on X11 ........................... yes
    QPA backends:
      DirectFB ............................... no
      EGLFS .................................. yes
      EGLFS details:
        EGLFS OpenWFD ........................ no
        EGLFS i.Mx6 .......................... no
        EGLFS i.Mx6 Wayland .................. no
        EGLFS RCAR ........................... no
        EGLFS EGLDevice ...................... yes
        EGLFS GBM ............................ no
        EGLFS VSP2 ........................... no
        EGLFS Mali ........................... no
        EGLFS Raspberry Pi ................... no
        EGLFS X11 ............................ yes
      LinuxFB ................................ yes
      VNC .................................... yes
      Mir client ............................. no
    

    The system should be an Ubuntu 18.04 and X11 is running. Is there a certain lib missing in order to have this qpa appearing or something like this?

    Thanks,
    Bodo


  • Lifetime Qt Champion

    Hi,

    From the looks of it, you are missing the xkbcommon development package.



  • @sgaist

    Thanks, but this was already installed.

    I now took another route. Instead of using the Qt from the tarball I cloned the 5.13.1 from the git repo and basically followed these steps: https://wiki.qt.io/Building_Qt_5_from_Git

    When running configure I now see this:

    Features used by QPA backends:
      evdev .................................. yes
      libinput ............................... yes
      INTEGRITY HID .......................... no
      mtdev .................................. yes
      tslib .................................. no
      xkbcommon .............................. yes
      X11 specific:
        XLib ................................. yes
        XCB Xlib ............................. yes
        EGL on X11 ........................... yes
    QPA backends:
      DirectFB ............................... no
      EGLFS .................................. yes
      EGLFS details:
        EGLFS OpenWFD ........................ no
        EGLFS i.Mx6 .......................... no
        EGLFS i.Mx6 Wayland .................. no
        EGLFS RCAR ........................... no
        EGLFS EGLDevice ...................... yes
        EGLFS GBM ............................ yes
        EGLFS VSP2 ........................... no
        EGLFS Mali ........................... no
        EGLFS Raspberry Pi ................... no
        EGLFS X11 ............................ yes
      LinuxFB ................................ yes
      VNC .................................... yes
      Mir client ............................. no
      XCB:
        Using system-provided XCB libraries .. yes
        XCB XKB .............................. yes
        XCB XInput ........................... yes
        Native painting (experimental) ....... yes
        GL integrations:
          GLX Plugin ......................... yes
            XCB GLX .......................... yes
          EGL-X11 Plugin ..................... yes
    

    .. which is looking way better and I can run my test app now.
    Don't know what's the difference between the codebases..

    Best,
    Bodo


  • Lifetime Qt Champion

    Just a wild guess: you installed libxkbcommon-dev after running configure. You then called configure again but without cleaning up first. Hence the test wasn't run again.


Log in to reply