Important: Please read the Qt Code of Conduct -

Trouble with windeployqt.exe

  • Hello everyone,
    I am trying to create a functional file exe of a program that I made in qt, using QML for the UI; but when I tried to run the .exe after running the windeployqt. exe something is wrong and the system doesnt open the application.
    These are the steps that I followed:
    1-First of all I change the mode of my kit MSVC2017 32 bits from debug to release.
    2-Secondtly I run the code and the code that I made appeared.
    3-Then, I go to the console MSVC2017-32 bits and I went to the folder where it is the file .exe that was made with the release.
    4-I run the command windeployqt.exe . (with a dot at the end)
    5-The command make the folder and files, but when I go to run the file .exe it makes nothing.

    Does anyone know what is wrong?

  • @Dooham Ok I have seen my error. I just had to put the following command:
    windeployqt --qmldir The route until my qml files in the project folder The route until my release file

    Like this:

Log in to reply