Necessitas on emulator



  • Hi all,
    I have just installed necessitas and android sdk. I setup qtcreator following the wiki and I have generated a default project. I started also the emulator within qtcreator. When I compile it, its ok, but when I run it it tell me that can't copy the binary file. In the build directory it doesn't exist
    here the output:

    @Running build steps for project untitledandroid...
    Configuration unchanged, skipping qmake step.
    Starting: "/usr/bin/make" -w
    make: Entering directory /home/deimos/Documents/workspace/prove/untitledandroid-build-android' /opt/necessitas/android-ndk-r5c/toolchains/arm-linux-androideabi-4.4.3/prebuilt/linux-x86/bin/arm-linux-androideabi-g++ --sysroot=/opt/necessitas/android-ndk-r5c/platforms/android-8/arch-arm/ -L/opt/necessitas/android-ndk-r5c/toolchains/arm-linux-androideabi-4.4.3/prebuilt/linux-x86/bin/../lib/gcc/arm-linux-androideabi/4.4.3 -Wl,-rpath-link=/opt/necessitas/android-ndk-r5c/platforms/android-8/arch-arm//usr/lib -Wl,--no-undefined -Wl,-z,noexecstack -shared -Wl,-soname,libuntitledandroid.so -Wl,-rpath=/data/data/eu.licentia.necessitas.ministro/files/qt/lib -o libuntitledandroid.so main.o qmlapplicationviewer.o qtmain_android.o moc_qmlapplicationviewer.o -L/opt/necessitas/android-ndk-r5c/sources/cxx-stl/gnu-libstdc++/libs/armeabi -L/opt/necessitas/android-ndk-r5c/platforms/android-8/arch-arm//usr/lib -L/opt/necessitas/Android/Qt/4762/armeabi-v7a/lib -lQtDeclarative -L/opt/necessitas/Android/Qt/4762/armeabi-v7a/lib -L/tmp/necessitas/android-ndk-r5c/sources/cxx-stl/gnu-libstdc++/libs/armeabi -L/tmp/necessitas/android-ndk-r5c/platforms/android-4/arch-arm//usr/lib -lQtScript -lQtSvg -lQtSql -lQtXmlPatterns -lQtNetwork -lQtGui -lQtCore -lstdc++ -lsupc++ -llog -lz -lm -ldl -lc -lgcc Copying application data... make: Leaving directory/home/deimos/Documents/workspace/prove/untitledandroid-build-android'
    The process "/usr/bin/make" exited normally.
    Copy Qt app & libs to Android package ...
    Can't copy 'untitledandroid' from '/home/deimos/Documents/workspace/prove/untitledandroid-build-android' to '/home/deimos/Documents/workspace/prove/untitledandroid-build-android'
    Error while building project untitledandroid (target: Android)
    When executing build step 'Packaging for Android'@

    what could I missed ? thanks
    I am using debian 64 bit


  • Moderators

    Not sure, as I've used actual device, not an emulator. The 'can't copy' line seems to indicate, that 'Packaging' step tries to copy 'untitledandroid' from one directory back to the vary same directory. Maybe that's the cause?



  • thanks for the reply.
    Yes, the packaging step tries to copy that binary file, but it is not there, it's not created. I just made a default project to test and I am new to this. I read somewhere that a "android/libs/armeabi/<projectName.so>" should be created, but its not.
    In a shell, I tried to do 'ant release' under 'android' directory, and it create the apk file. Then with 'ant install' its been installed correctly into emulator. When I run it in the emulator it ask for ministro but cannot find it even if I set in Deploy Configuration to install it :(
    So I think there is something wrong in my installation or in some necessitas script, but I don't know where to put my fingers



  • I think waiting for next necessitas release (alpha 3) can help ... and It seems that it's not far now :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.