Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Installed a new Qt version 13.0 and the application has ceased to compile



  • Hi!
    Installed a new Qt version 13.0 and the application has ceased to compile.
    In version 12.3 the application was compiled.
    I get errors:
    The API level specified for the APK is lower than the minimum for the bundle.
    The kit requires a minimum API level of 21.
    Error building/installing smstest project (kit: Android for armeabi-v7a (Clang Qt 5.13.0 for Android ARMv7))
    During the "Build Android APK" phase┬╗


  • Moderators

    Qt 5.13 does not support Android 4 anymore, hence this error. Check your AndroidManifest and make sure your minimal API is correct.



  • Put the minimum version Android 5.0 and got an error:
    [INSTALL_FAILED_UPDATE_INCOMPATIBLE]


  • Moderators

    You need to remove the previous installation of the app from your phone, then install the new one.


Log in to reply