Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

How to hide this F1?



  • 0_1561074932815_c13ec1b0-48d8-41a0-9767-0cf5f7c45400-image.png

    I can't find settings for this.
    I tried unbind F1, but it's still show this F1.
    Do I need to roll back to an older version for fix it, lol?


  • Lifetime Qt Champion

    Hi @Melie,

    I don't think there is a setting for it, because nobody requested it so far.

    But what do you really want to achive? Do you want a tooltip without the "F1" key symbol in it?

    Regards

    Edit: This might be related to Clang Code Model. You can try to disable it in Help > About Plugins



  • >Do you want a tooltip without the "F1" key symbol in it?
    Yes.
    >You can try to disable it in Help About Plugins
    Hm, i try disable all except "cppEditor", "cppTools", "TextEditor" and "ProjectManager", but it's still show F1.

    I installed qtCreator 4.7.2 and everything works well. Now this looks twice as compact and four times less annoying.
    0_1561125721877_def0003a-88df-425e-a769-f1b7d90e8f48-image.png

    Thank you, I apologize for the time spent, I did not think that at least someone will answer. I will stay on 4.7.2 until there are adequate solutions.


  • Lifetime Qt Champion

    @Melie

    Thank you, I apologize for the time spent, I did not think that at least someone will answer. I will stay on 4.7.2 until there are adequate solutions.

    If that is important for you, plesse report it on bugreports.qt.io

    Otherwise it will stay like this forever.

    Regards


Log in to reply