Planned maintenance has been done but it did not solve the problem. So work will continue on this and a new time for trying updates will be announced asap.

Unable to build QtWebengine on Raspberry Pi 3



  • I am trying to build QtWebengine on Raspberry Pi 3. Qt base and other components was successfully built, but when I try to run qmake in QtWebengine directory I get this:

    pi@raspberrypi:~/qt5/qtwebengine$ /usr/local/qt5/bin/qmake 
    
    Running configuration tests...
    Done running configuration tests.
    
    Configure summary:
    
    Qt WebEngine:
      Embedded build ......................... yes
      Pepper Plugins ......................... no
      Printing and PDF ....................... no
      Proprietary Codecs ..................... no
      Spellchecker ........................... yes
      Native Spellchecker .................... no
      WebRTC ................................. no
      Use System Ninja ....................... no
      Geolocation ............................ no
      WebChannel support ..................... yes
      Use v8 snapshot ........................ yes
      Kerberos Authentication ................ no
      Building v8 snapshot supported ......... yes
      Use ALSA ............................... yes
      Use PulseAudio ......................... no
      Optional system libraries used:
        re2 .................................. no
        icu .................................. no
        libwebp, libwebpmux and libwebpdemux . no
        opus ................................. no
        ffmpeg ............................... no
        libvpx ............................... no
        snappy ............................... no
        glib ................................. no
        zlib ................................. no
        minizip .............................. no
        libevent ............................. no
        jsoncpp .............................. no
        protobuf ............................. no
        libxml2 and libxslt .................. no
        lcms2 ................................ no
        png .................................. no
        JPEG ................................. yes
        harfbuzz ............................. no
        freetype ............................. no
        x11 .................................. no
      Required system libraries:
        fontconfig ........................... no
        dbus ................................. no
        nss .................................. no
        khr .................................. yes
        glibc ................................ yes
      Required system libraries for qpa-xcb:
        libdrm ............................... no
        xcomposite ........................... no
        xcursor .............................. no
        xi ................................... no
        xtst ................................. no
    
    WARNING: Thumb instruction set is required to build ffmpeg for QtWebEngine.
    
    Qt is now configured for building. Just run 'make'.
    Once everything is built, you must run 'make install'.
    Qt will be installed into '/usr/local/qt5'.
    
    Prior to reconfiguration, make sure you remove any leftovers from
    the previous build.
    
    
     
    pkg-config is required
    QtWebEngine will not be built.
    

    fontconfig fontconfig-dev are installed(the same as dbus and nss). What is the problem?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Take a look at the Required system libraries list. They are all missing.



  • Hi! Thank you for your reply. As I said fontconfig and fontconfig-dev are installed, but qmake does not see them. The same is with dbus-1-dev and nss. Why?



  • Moreover, I run this on my system:

    $ pkg-config --libs fontconfig
    -lfontconfig -lfreetype
    
    pi@raspberrypi:~/qt5/qtwebengine$ pkg-config --cflags fontconfig
    -I/usr/include/freetype2
    
    pi@raspberrypi:~/qt5/qtwebengine$ ldconfig -p | grep fontconfig
            libfontconfig.so.1 (libc6,hard-float) => /usr/lib/arm-linux-gnueabihf/libfontconfig.so.1
            libfontconfig.so (libc6,hard-float) => /usr/lib/arm-linux-gnueabihf/libfontconfig.so
    

    It looks like that with fontconfig everything should be ok...


  • Lifetime Qt Champion

    Check the build logs, you'll see the where the errors happen.

    You are also missing pkg-config.

    Note that once you installed these package, you should launch configure from a clean state. The best would be to do an out of source build so you can easily nuke the build folder to start fresh.



  • How can I miss pkg-config if I just run it from the command line? Also, I've not installed these dev libraries AFTER configure of QtBase, they just were already installed.


  • Lifetime Qt Champion

    Hence taking a look at the logs generated during the configure phase might give you the information you need about that.


Log in to reply