QtCreator do not appears on higher screen resolution despite the qt creator process is running on win10



  • Hi
    A day ago I updated automatically qtcreator to 4.9.1 version. To my suprise when I clicked on qt creator icon nothing showed on my two Dell displays.
    I add that I use two Dell display 25" 2560x1440 resolution. So I decided to reinstal Qt and there was no any improvement. I have noticed that after clicking the qt creator icon
    the qt creator prossess is running( on windows 10). So I disconnected the two displays of my laptop and discovered that this time everything is ok.
    Qt is running very well on my laptop screen with 1920x1080 resolution. Any ideas how to make qt creator will runn well on my Dell display with higher resolution 2560x1440.
    The one way to fix it now was disconect the two dispalys of my laptop and start Qt creator then reconnect the two displays
    and then I see QtCreator running on my Dell displays. But believe me it is not handy moreover what I have just discovered
    is that after a fiew minutes of using it qt creator do not response. It is even not possible to close the soft.


  • Lifetime Qt Champion

    Hi,

    You can follow the suggestions provided in the HighDPI chapter of Qt's documentation.



  • I looked into HighDPI chapter of Qt's documentation and tried to change a fiew things in my dispalys settings like scaling etc but it unfortunately did not help.
    The true is that after updating qt creator from 4.9.0 to 4.9.1 I am not able to use it when I use external dispays. Simply when I disconnect them of my laptop everything is ok.
    Imagine you buy displays to extend your working area for coding but now you have to use built- in dispaly of your laptop. It is like comming back to the Stone age.

    I have just discovered that when I have only one dispaly connected (as external dispaly) qt Creator is working as expected. So it looks like problem is when I connect the second display and the two dyspalys have extended desctops.


  • Moderators

    @Slawomir_Piernikowski
    The issue is not with the dpi of your external monitors, but the fact that you're using them.

    QtCreator is drawn outside of all screens. That's why you see it, when you disconnect all screens but the native one.

    After closing, x & y are saved to be loaded for the next start. On Windows this is done in the Registry. -> After reinstall the old settings persist and its again positioned way of screen.

    My suggestion:
    highlight QtCreator (make sure it has active focus)
    Press `WindowsKey + arrow key (left or right) until it appears on the screen.



  • Thanks a lot your sugestion did the trick.... but unfotunetly the problem came back. I am a little bit confused for every other software like firefox, google chrome and other works fine. So is it a Qt Creator or Win10 or both causes a problem?????


Log in to reply