Nominate our 2022 Qt Champions!

Mapbox on ARM not working

  • Hi,
    I have a issue with a mapbox application on my raspberryPI. My application just displays a simple map using the plugin mapboxgl. On my PC the map works fine, but when I deploy the app on the raspberry, the application is running but the map is not displayed(just a blank screen).
    Here's the code I'm using:

    import QtQuick 2.0
    import QtQuick.Window 2.0
    import QtLocation 5.6
    import QtPositioning 5.6
    Window {
        width: 512
        height: 512
        visible: true
        Plugin {
            id: mapPlugin
            name: "mapboxgl" // "mapboxgl", "esri", ...
        Map {
            anchors.fill: parent
            plugin: mapPlugin
            center: QtPositioning.coordinate(41.38, 2.16) // Oslo
            zoomLevel: 14

    Any ideas or advices?


  • @bozhi do you have the plugin built for ARM as well?

  • Hi @Pablo-J.-Rogina, which plugin is? How is called? How do I install it?
    Also, Im using the QT 5.10. I think that by default, there is no mapboxgl plugin. So I have to install it manually, correct?

  • @bozhi
    Did You resolve this problem? I have blank screen too. I tried to compile Qt with GCC 9.1 with no succes, mapboxGL module is still not installed..

Log in to reply