Can't play videos with QT (Qmediaplayer, Udoo Neo Full, Udoobuntu 2)



  • Hello everyone, me again!
    I finally built my QT5 application for Udoobuntu 2 (I know there is not so much source around for that. So I can help anyone with that.). My application is a basic Video Player application which depends on Qmediaplayer.
    When I run glmark2 or something else that tests OpenGL ES2, it works without problems.
    But when I run my application or any QT application uses OpenGL (as hellogl_es2), It gives the error following, "Unable to find an X11 visual which matches EGL config".
    Full output;

    root@udooneo:/usr/lib/arm-linux-gnueabihf/qt5/examples/opengl/hellogl_es2# ./hellogl_es2
    xkbcommon: ERROR: x11: failed to get keymap from X server: unmet condition in get_explicits(): wire->keycode >= keymap->min_key_code && wire->keycode <= keymap->max_key_code
    Warning: EGL suggested using X Visual ID 33 (RGB565) for EGL config 5 (RGB444), but this is incompatable
    Unable to find an X11 visual which matches EGL config 5
    Warning: EGL suggested using X Visual ID 33 (RGB565) for EGL config 1 (RGB444), but this is incompatable
    Unable to find an X11 visual which matches EGL config 1
    Warning: EGL suggested using X Visual ID 33 (RGB565) for EGL config 1 (RGB444), but this is incompatable
    Unable to find an X11 visual which matches EGL config 1
    Warning: EGL suggested using X Visual ID 33 (RGB565) for EGL config 1 (RGB444), but this is incompatable
    Unable to find an X11 visual which matches EGL config 1
    Warning: EGL suggested using X Visual ID 33 (RGB565) for EGL config 1 (RGB444), but this is incompatable
    Unable to find an X11 visual which matches EGL config 1
    Warning: EGL suggested using X Visual ID 33 (RGB565) for EGL config 1 (RGB444), but this is incompatable
    Unable to find an X11 visual which matches EGL config 1
    Warning: EGL suggested using X Visual ID 33 (RGB565) for EGL config 1 (RGB444), but this is incompatable
    Unable to find an X11 visual which matches EGL config 1
    Segmentation fault
    

    Please help me guys, I can feel that I am so close!
    Best,
    Onur



  • build hellogl_es2 with debug info
    $gdb hellogl_es2

    r
    bt
    cut-n-paste here



  • @vladstelmahovsky said in Can't play videos with QT (Qmediaplayer, Udoo Neo Full, Udoobuntu 2):

    build hellogl_es2 with debug info
    $gdb hellogl_es2

    r
    bt
    cut-n-paste here

    Thanks for your reply, but I couldn't understand. How can I add this "info" to debug?



  • @closx just make a debug build



  • @vladstelmahovsky said in Can't play videos with QT (Qmediaplayer, Udoo Neo Full, Udoobuntu 2):

    @closx just make a debug build

    I already made a debug version. But does not works.
    By the way, application runs. But when I gonna play a video, it gives the eror.
    Thx for your answer again :D


  • Lifetime Qt Champion

    Hi,

    Are you using a cross-compiled version of Qt ?
    What if you force the backend to use EGL ?



  • @closx so, application not crashing anymore after EGL errors?
    Have you tried to build Qt5 manually? May be its better to use an Yocto builds?



  • @SGaist said in Can't play videos with QT (Qmediaplayer, Udoo Neo Full, Udoobuntu 2):

    Hi,

    Are you using a cross-compiled version of Qt ?
    What if you force the backend to use EGL ?

    Yes, I am using a cross-compiled version. Everything works fine with the QT on board. Only QT applications they works with the OpenGL are not working. I face the same issue when I try to execute OpenGL examples of QT.
    And I could not understand what you mean by "forcing the backend to use EGL". -sorry for being noob-

    @vladstelmahovsky said in Can't play videos with QT (Qmediaplayer, Udoo Neo Full, Udoobuntu 2):

    @closx so, application not crashing anymore after EGL errors?
    Have you tried to build Qt5 manually? May be its better to use an Yocto builds?

    Application never crashes. It works fine. Only parts of application that needs OpenGL (as playing a .mp4 video) does not works.
    Do you mean building the QT from source to my board? I mean, I installed Qt by the commands,

    sudo apt-get install build-essential qtcreator qt5-default libqt5multimedia5
    

    I did infinity attempts of using Yocto with that crazy board :D I guess it is worse to use Yocto on UDOO.


  • Lifetime Qt Champion

    See the Qt for Embedded Linux chapter in Qt's documentation.



  • @SGaist said in Can't play videos with QT (Qmediaplayer, Udoo Neo Full, Udoobuntu 2):

    See the Qt for Embedded Linux chapter in Qt's documentation.

    Hello SGaist,
    Thank you for your answer. I finally got what is wrong.
    UDOO NEO CANNOT PLAY VIDEOS!
    Processor of Udoo Neo (imx6something) does not support video decoding. So there is no decoder. You can only play very small video files (like 100px400p 10fps) with X11 output of VLC. And you cannot set it on QT. If you would set anyway, it would be so low on performance.
    I finally figured it out, I am being busy with something impossible for 2 months :D
    Thanks everyone on this forum, anyway!


Log in to reply