Disable system (linux) "unresponsive app" blocking window when debugging?



  • Hello,
    I am using qtcreator on ubuntu 18.04 (default gnome).
    When I launch the debugger from qtcreator, I invariably get after a few seconds/minutes of stepping through code a "application is not responsive : would you like to kill or wait?" warning. This is a modal window, blocking quite all on the system.

    I tried placing "&>/dev/null" as a command line argument in the project - execution settings, that did not solve my issue.
    Any clue?



  • Nevermind, this long-running terrible bug has been fixed.
    https://gitlab.gnome.org/GNOME/gnome-shell/issues/273
    Solution is to upgrade gnome-shell, 3.32+ should be fine.


Log in to reply