Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Unable to generate an APK package via androiddeployqt.



  • Greetings. I am facing this issue when I type this command

    _JAVA_OPTIONS="-Xmx10240m -XX:-UseGCOverheadLimit" /home/nnikhil/Qt5.12.1/5.12.1/android_armv7/bin/androiddeployqt --input android-libandroid_appman.so-deployment-settings.json --output android-build --android-platform android-28 --jdk /usr/lib/jvm/jdk1.8.0_201 --gradle
    

    Instead of a successful output, I am getting the following error:

    Generating Android Package
      Input file: android-libandroid_appman.so-deployment-settings.json
      Output directory: /home/nnikhil/MyCodeBase/build_android-appman/android-build/
      Application binary: /home/nnikhil/MyCodeBase/build_android-appman/libandroid_appman.so
      Android build platform: android-28
      Install to device: No
      -- Skipping /home/nnikhil/Qt5.12.1/5.12.1/android_armv7/plugins/iconengines/libqsvgicon.so. It has unmet dependencies: lib/libQt5Svg.so.
      -- Skipping /home/nnikhil/Qt5.12.1/5.12.1/android_armv7/plugins/imageformats/libqsvg.so. It has unmet dependencies: lib/libQt5Svg.so.
    The file name of external library /lib/klibc-k3La8MUnuzHQ0_kG8hokcGAC0PA.so must begin with "lib" and end with the suffix ".so".
    
    

    Does anybody know what this issue is, and the solution to it? I've been unsuccessful in Googling it, and not much support is available in any forum or developer blogspots either.

    Any help is appreciated. :-)



  • Any solution? @SGaist, @jsulm, @sierdzio, @dheerendra, @aha_1980, or any of our Qt family's top minds? I feel that there is an obvious solution around the corner, and am feeling dumb for not being able to think of it. :-(


  • Qt Champions 2017

    what is the following library ? Are you linking this in your project ?

    /lib/klibc-k3La8MUnuzHQ0_kG8hokcGAC0PA.so



  • @dheerendra Yes, that strange library's name is not supposed to be generated in the file 'android-libandroid_appman.so-deployment-settings.json'. This was due to path issues, and I have fixed it. I performed another clean build giving precise paths and that obscure library's name didn't appear. I also could generate an APK of the project.

    Thank you for replying. I will mark this topic as solved.


Log in to reply