Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QPrintDialog



  • I have a Qt app that was developed years ago on Windows Qt. I has be working (compiling and exe) through several QtCreator versions. After several years I am again interested in desktop Linux and insalled Mint Cinnamon 19.1. I can do most anything I could do on windows except port my Qt app. On Mint I installed Qt 5.10.1 (same as on Window) and compiled my app. Everything works except when printing using QPrintDialog. The dialog executes but has a different qui than on windows. When attempting to print my Cannon printer gave error "Sendeng document in A4, printe set for US Letter". I selected Properties from the PrintDialog and set it to US Letter. Printed again and got the same error. Tried again and selected Properties only to find it was reset to A4. Set it back to USLetter, selected print, got same error. Every time Print is selected, for some reason paper type is set to A4? The code is exactly the same as on Windows. Any ideas?



  • unfortunately too many of the linux distros choose A4 as the default media size. The print gui is probably getting its information from cups, the unix printing system. I fight with this incorrect media size issue all the time. when you figure out how to reliably and permanently change the cups default media size to letter for all registered printers then please post the solution.


Log in to reply