Skip to content
QtWS25 Call for Papers
  • 0 Votes
    5 Posts
    286 Views
    H

    Just changing the root widget of my application from QWidget to QQuickWidget fixed the problem. Well, that was way easier than I expected! Thanks for the help.

  • 0 Votes
    8 Posts
    794 Views
    A

    @Christian-Ehrlicher @SGaist I think I managed to solve the problem. The problem is that the webp library is not included in the Qt installation directory. I mean, by default, in the path /Users/user/Qt/6.4.2/macos/plugins/imageformats, only the following libraries are included in my case:

    libqgif.dylib libqico.dylib libqjpeg.dylib libqsvg.dylib

    I understand that for this reason, when macdeployqt generates the final application directory, it does not include the webp library.

    However, I have been able to find much more libraries in the path /Users/user/Qt/QtDesignStudio/qt6_design_studio_reduced_version/plugins/imageformats, including the following one:

    libqwebp.dylib

    All I had to do is to copy libqwebp.dylib
    to /Users/user/Qt/6.4.2/macos/plugins/imageformats, build the final project executable again, and it works.

    Thanks a lot to both of you! :))

  • 0 Votes
    3 Posts
    224 Views
    S

    @Christian-Ehrlicher
    I have used the -appstore-compliant option on the final .app made with Xcode. I used nm on the .app after using macdeployqt and it still showed the presence of the two APIs within it.

    I think I will have to make my own custom Qt using the appstore-compliant feature.

    Surely you mean I have to compile Qt with the "appstore-compliant" feature turned ON?

    I know it is supposed to be turned ON by default for Qt downloaded through the maintenancetool. Maybe the Qt 6.4.2 that's available through the maintenance tool wasn't built with the appstore-compliant feature turned ON?